We are currently experiencing an outage with our Chrome Extension
Incident Report for Prelude
Resolved
This incident has been resolved.
Posted Apr 11, 2023 - 19:10 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 11, 2023 - 17:11 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 11, 2023 - 15:23 UTC
Investigating
We are currently investigating this issue.
Posted Apr 11, 2023 - 15:14 UTC
This incident affected: Coordinate Application (Web Application).