Elevated error rate from Google APIs causing degraded Prelude performance
Incident Report for Prelude
Resolved
This incident has been resolved.
Posted Sep 21, 2023 - 17:00 UTC
Investigating
The Google Calendar API is experiencing a partial outage resulting in degraded application performance in Prelude. We are monitoring this issue and will provide an update once it's resolved.
Posted Sep 21, 2023 - 14:31 UTC
This incident affected: Coordinate Application (Web Application, Reminders and Notifications, Scheduling Solver), Office Software Suites (Google Apps Calendar), and Candidate Bookings.