We are currently experiencing issues with CSV Reports downloading blank or with unintelligible characters
Incident Report for Prelude
Resolved
This incident has been resolved.
Posted Apr 04, 2023 - 16:20 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 04, 2023 - 15:48 UTC
Investigating
We are currently investigating.
Posted Apr 04, 2023 - 15:34 UTC
This incident affected: Coordinate Application (Web Application).